We have identified the cause of this error and are working to resolve it for you. We will provide an update here once the fix is deployed.
Posted Nov 06, 2025 - 14:02 EST
Investigating
We have identified the cause of this error and are working to resolve it for you. We will provide an update here once the fix is deployed. Please reference this page for updates.
Until the fix is available, you can import batches through Settings.
Posted Nov 06, 2025 - 12:06 EST
This incident affects: Blackbaud Financial Edge NXT® (Financial Edge NXT).