We have identified an intermittent issue causing a delay in delivery stats for a subset of email campaigns. Our engineers are continuing to investigate.
Posted Aug 06, 2025 - 11:07 EDT
Investigating
We have identified an intermittent issue causing a delay in delivery stats for a subset of email campaigns. Our engineers are investigating.
Posted Aug 06, 2025 - 10:12 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).