We are aware of a delay in the appearance of certain transactions in the Blackbaud Merchant Services portal made through our latest Checkout platform. While transaction processing is NOT impacted, there may be a delay between when a transaction is processed and when it appears within the Blackbaud Merchant Services portal. Transaction reporting in your solution (e.g. Luminate Online or Raiser's Edge NXT) should also NOT be affected.
Any process relying on the presence of transactions in the BBMS portal (e.g. refunding a transaction) will return an error. Users will also not be able to report on or refund in the BBMS portal until the transaction appears.
Posted Dec 02, 2025 - 17:34 EST
Investigating
We are aware of a delay in the appearance of certain transactions in the Blackbaud Merchant Services portal made through our latest Checkout platform. While transaction processing is NOT impacted, there may be a delay between when a transaction is processed and when it appears within the Blackbaud Merchant Services portal. Transaction reporting in your solution (e.g. Luminate Online or Raiser's Edge NXT) should also NOT be affected.
Any process relying on the presence of transactions in the BBMS portal (e.g. refunding a transaction) will return an error. Users will also not be able to report on or refund in the BBMS portal until the transaction appears.
Our teams are working to resolve this delay as quickly as possible. Please check this page for further updates.
Posted Dec 02, 2025 - 16:29 EST
This incident affected: YourCause® (YourCause® CSRconnect®), Blackbaud Altru®, Blackbaud CRM™, Blackbaud Luminate Online® (Blackbaud Luminate Online®, Team Raiser), and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).