Resolved Issue Alert – Team Approach - #2019081503
Incident Report for Blackbaud
Resolved
We are aware of an issue where a small subset of customers may have experienced slowness pulling reports from the FTP site. The issue has now been resolved.

Please continue to reference this page for updates.
Posted about 1 month ago. Aug 15, 2019 - 11:35 EDT