Active Issue Alert – Blackbaud Financial Aid Management- #000642445

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 12:31 EDT

Identified

We are investigating an issue impacting some of our customers. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Oct 28, 2025 - 12:08 EDT
This incident affected: Blackbaud Financial Aid Management™.