Active Issue Alert – Education Edge, Financial Edge, Raiser's Edge - #2019082601
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted 25 days ago. Aug 26, 2019 - 12:40 EDT
Update
We are continuing to investigate this issue.
Posted 25 days ago. Aug 26, 2019 - 12:32 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted 26 days ago. Aug 26, 2019 - 12:25 EDT
This incident affected: Education Edge (Education Edge) and Financial Edge, Raiser's Edge.