Active Issue Alert – Blackbaud Church Management, Raiser's Edge NXT - #000154523
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Aug 04, 2020 - 14:32 EDT
Update
We have identified an issue impacting Social Posting that prevents users from connecting a new Twitter account or posting to Twitter. Please continue to reference this page for updates. Next update 9:00 AM EDT - 8/5/2020.
Posted Aug 04, 2020 - 11:20 EDT
Update
We have identified an issue impacting Social Posting that prevents users from connecting a new Twitter account or posting to Twitter. Please continue to reference this page for updates. Next update 9:00 AM EDT - 8/3/2020.
Posted Aug 01, 2020 - 09:33 EDT
Update
We have identified an issue impacting Social Posting that prevents users from connecting a new Twitter account or posting to Twitter. Please continue to reference this page for updates. Next update 9:00 AM EDT - 7/31/2020.
Posted Jul 30, 2020 - 13:50 EDT
Update
We have identified an issue impacting Social Posting that prevents users from connecting a new Twitter account or posting to Twitter. Please continue to reference this page for updates. Next update 9:00 AM EDT - 7/30/2020.
Posted Jul 29, 2020 - 17:13 EDT
Update
We have identified an issue impacting Social Posting that prevents users from connecting a new Twitter account or posting to Twitter. Please continue to reference this page for updates. Next update 5:00 PM EDT - 7/29/2020.
Posted Jul 29, 2020 - 12:51 EDT
Investigating
We have identified an issue impacting Social Posting. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 29, 2020 - 12:07 EDT
This incident affected: Blackbaud Church Management™ and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).