Active Issue Alert – Blackbaud Learning Management System - #2019082801
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted 23 days ago. Aug 28, 2019 - 15:55 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted 23 days ago. Aug 28, 2019 - 15:28 EDT
This incident affected: Blackbaud Education Management Solutions (Blackbaud Learning Management System).