Active Issue Alert – Financial Aid Management - 000657084

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 13:09 EST

Investigating

We have identified an issue impacting a subset of customers receiving the error "Login was unsuccessful" when attempting to login to the solution. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Feb 03, 2026 - 11:41 EST
This incident affected: Blackbaud Financial Aid Management™.