Active Issue Alert – Luminate Online - #000684337

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 21:15 EDT

Update

We have identified an issue causing a delay with recurring pledges for a subset of customers. Our engineers have identified a solution and are continuing to work on implementing it now. Next update will be at 8am EST.
Posted Jul 20, 2026 - 21:04 EDT

Identified

We have identified an issue causing a delay with recurring pledges for a subset of customers. Our engineers have identified a solution and are working on implementing it now. Next update will be at 9pm EST.
Posted Jul 20, 2026 - 18:31 EDT

Investigating

We have identified an issue causing a delay with recurring pledges for a subset of customers. Our engineers are currently investigating.
Posted Jul 20, 2026 - 15:47 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).