We are aware of a subset of customer sites that are inaccessible. This includes admin login as well as web forms. Engineers are working on resolving the issue as quickly as possible. Please reference this page for further updates.
Posted Feb 21, 2026 - 19:24 EST
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Feb 21, 2026 - 19:09 EST
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).