Resolved Issue Alert – Email Services - #2019081906
Incident Report for Blackbaud
Resolved
A short service issue impacting some of our customers is now resolved and emails are now processing. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted about 1 month ago. Aug 19, 2019 - 21:56 EDT