We continue to investigate an intermittent issue impacting a subset of customers. This may result in an error with form submissions or integration interruptions. We have disabled the recurring pledge task while our our engineers work toward a resolution. Please continue to monitor this page for updates.
Posted Jul 27, 2026 - 14:57 EDT
Investigating
We have identified an issue intermittently impacting a subset of customers. This may result in an error when submitting forms or interrupted integrations. Our engineering team is actively investigating and working toward a resolution. Please continue to monitor this page for the latest updates.
Posted Jul 27, 2026 - 14:11 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).