Active Issue Alert – Blackbaud Merchant Services - #2018021602
Incident Report for Blackbaud
Resolved
We are aware that some of our Merchant Services customers may have experience brief latency. We implemented a fix that may have, for a small subset of customers, resulted in up to 6-7 seconds of interrupted services. This issue is now resolved. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Feb 16, 2018 - 15:58 EST
Investigating
We are aware that some of our Merchant Services customers may experience a moment of brief latency. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Feb 16, 2018 - 15:26 EST
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™).