Due to an ongoing network issue with our vendor, DeceasedRecordFinder™ and AddressFinder™ services remain temporarily unavailable to Blackbaud customers. We are diligently working with this vendor to determine a potential restoration timeline as well as exploring alternative solutions for our customers. We will continue to communicate updates regarding service availability through our status page.
Posted Oct 10, 2025 - 10:14 EDT
Update
DeceasedRecordFinder™ and AddressFinder™ services continue to be unavailable to our customers due to a network issue with the vendor who enables these services. This vendor has not provided a restoration timeline. With the upcoming giving season in mind, we continue to work with the vendor and are exploring alternative options to re-enable these services or establish a new vendor. We will update customers about the availability of these services via our status page messaging.
Posted Oct 01, 2025 - 16:17 EDT
Update
DeceasedRecordFinder™ and AddressFinder™ services continue to be unavailable to our customers due to a network issue with the vendor who enables these services. This vendor has not provided a restoration timeline. With the upcoming giving season in mind, we continue to work toward making these services available and will update customers about any changes to these services via our status page messaging.
Posted Sep 26, 2025 - 10:42 EDT
Investigating
DeceasedRecordFinder™ and AddressFinder™ functionality within Blackbaud solutions is currently unavailable due to a network issue with the vendor who enables these services. We are working with the vendor to restore functionality for customers to resume their use of these services. We will update customers about the availability of these services via our status page messaging.
Posted Sep 19, 2025 - 14:36 EDT
This incident affects: Blackbaud Altru®, Blackbaud CRM™, Blackbaud eTapestry® and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).