We have identified an issue which is preventing some donor data from appearing in donation reports for the period from Monday 8th December. There is also a delay to some outgoing email. Our engineers are working to resolve this as quickly as possible. Please continue to reference this page for updates.
Posted Dec 09, 2025 - 05:46 EST
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause and we have all the appropriate engineers available to get your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted Dec 09, 2025 - 05:45 EST
This incident affected: JustGiving® from Blackbaud®.