Active Issue Alert – Financial Edge NXT, Raiser's Edge NXT and YourCause - 000668835

Incident Report for Blackbaud

Resolved

An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Apr 14, 2026 - 14:08 EDT

Update

We have identified an issue impacting a subset of customers accessing SFTP files using recent versions of third party application, FileZilla. We are actively monitoring the situation. Please continue to reference this page for updates.

As a temporary workaround, customers could use a stable version of FileZilla (such as 3.69.1 or 3.69.6), where connectivity has been confirmed to work as expected or another SFTP client to access files.
Posted Apr 14, 2026 - 10:28 EDT

Update

We have identified an issue impacting a subset of customers accessing SFTP files using a third party application. Our engineers are still working with a third party to diagnose the root cause and work toward a resolution. Please continue to reference this page for updates.
Posted Apr 14, 2026 - 10:09 EDT

Investigating

We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Apr 14, 2026 - 09:44 EDT
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT), Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®), and Grateful Patient Solution.