Active Issue Alert – Blackbaud ID, Financial Edge NXT, Raiser's Edge NXT - #000553809
Incident Report for Blackbaud
Resolved
An issue causing intermittent degraded performance, including intermittent login issues and errors is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Sep 18, 2024 - 09:06 EDT
Update
We are aware of issues with intermittent degraded performance, including intermittent login issues and errors. If a user is unable to log in, subsequent attempts to log in may be successful. Engineers have resolved the incident but are continuing to monitor the error. Next update at 9 AM EST on 9/18/2024.
Posted Sep 17, 2024 - 21:55 EDT
Monitoring
We are aware of issues with intermittent degraded performance, including intermittent login issues and errors. If a user is unable to log in, subsequent attempts to log in may be successful. Engineers have resolved the incident but are continuing to monitor the error. Next update at 4PM EST.
Posted Sep 17, 2024 - 12:09 EDT
Investigating
We are aware of issues with intermittent degraded performance, including intermittent login issues and errors. If a user is unable to log in, subsequent attempts to log in may be successful. Engineers are actively working to address the issue as quickly as possible.
Posted Sep 17, 2024 - 11:32 EDT
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT), Blackbaud.com (Blackbaud ID), and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).