Active Issue Alert – Blackbaud Raiser's Edge NXT® - 000654604

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 18:38 EST

Update

We are continuing to investigate this issue.
Posted Jan 19, 2026 - 18:37 EST

Update

We are continuing to investigate this issue.
Posted Jan 19, 2026 - 18:36 EST

Update

'We have identified an issue impacting some of our customers when launching the database view. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.'
Posted Jan 19, 2026 - 17:53 EST

Update

'We have identified an issue impacting some of our customers when launching the database view. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.'
Posted Jan 19, 2026 - 17:52 EST

Investigating

Unable to View S21 s23 , S24, S51, and S52
Posted Jan 19, 2026 - 17:49 EST
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).