Active Issue Alert – Altru, Financial Edge NXT , Raiser's Edge NXT, Education Management, Grantmaking, Merchant Services, Online Giving- 000601918

Incident Report for Blackbaud

Resolved

An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Apr 22, 2025 - 14:59 EDT

Update

We are continuing to investigate this issue.
Posted Apr 22, 2025 - 14:45 EDT

Investigating

We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 22, 2025 - 14:35 EDT
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™), Blackbaud Grantmaking™ (Blackbaud Grantmaking™), Blackbaud Altru®, Financial Edge®, Blackbaud Financial Edge NXT® (Financial Edge NXT), Blackbaud Education Management Solutions (Blackbaud Learning Management System), and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).