Active Issue Alert – Blackbaud Financial Edge NXT® - Financial Edge NXT - 000646884

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 11:02 EST

Update

A small subset of customers are receiving errors when attempting to open report parameters in Analysis > Reports. Our engineers are working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Nov 20, 2025 - 10:09 EST

Update

We are currently investigating the issue.
Posted Nov 20, 2025 - 10:08 EST

Investigating

A small subset of customers are receiving errors when attempting to open report parameters in Analysis > Reports. Our engineers are working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Nov 20, 2025 - 10:02 EST
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT).