Active Issue Alert – signin.blackbaud.com (BBID), Altru, Financial Edge NXT, eTap, BB NetCommunity, BB Church Management, BB Employee Giving, BB.com, BB Guided Fundraising, ResearchPoint, Raiser's Edge NXT - 000320322
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jan 14, 2022 - 22:02 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2022 - 17:35 EST
Update
We identified an issue that may prevent you from signing in with your Blackbaud ID if you use SMS as a multifactor authentication option. We’re working to resolve the issue as quickly as possible. Please continue to check this page for updates. The next update will be 6:00 PM EST.
Posted Jan 14, 2022 - 13:55 EST
Update
We identified an issue that may prevent you from signing in with your Blackbaud ID if you use SMS as a multifactor authentication option. We’re working to resolve the issue as quickly as possible. Please continue to check this page for updates. The next update will be 2:00 PM EST or as soon as we have more information available.
Posted Jan 14, 2022 - 10:59 EST
Update
We identified an issue that may prevent you from signing in with your Blackbaud ID or using features in the solutions below. We’re working to diagnose and resolve the issue as quickly as possible. Please continue to check this page for updates. The next update will be 2:00 PM EST.
Posted Jan 14, 2022 - 10:41 EST
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jan 14, 2022 - 10:17 EST
This incident affected: Blackbaud.com (Blackbaud.com, Blackbaud ID), Blackbaud Fundraiser Performance Management (Blackbaud Fundraiser Performance Management (FPM)), Blackbaud Grantmaking (Blackbaud Grantmaking), Financial Edge NXT (Accounts Payable API, Financial Edge NXT, General Ledger API, Statistical Unit API, Treasury API), Blackbaud Education Management Solutions (Blackbaud School Website System, Blackbaud Enrollment Management System, Blackbaud Learning Management System, Blackbaud Student Information System, Core Functionality, School API, Blackbaud Billing Management (EAP), Smart Aid), Raiser's Edge NXT (Constituent API, Fundraising API, Gift API, Opportunity API, Raiser's Edge NXT), Altru, Blackbaud Church Management, Blackbaud Employee Giving, Blackbaud Employee Volunteering, Blackbaud Guided Fundraising, DonorCentral NXT, eTapestry, ResearchPoint, WealthPoint, Blackbaud Merchant Services (Payments API), and Luminate (Luminate Online).