Active Issue Alert –Multiple Products- 000540350
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jul 23, 2024 - 10:48 EDT
Update
A fix has been implemented and we continue to monitor the environment for any residual impact. Thank you for your patience. Continue to monitor this page for further updates.
Posted Jul 22, 2024 - 12:30 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2024 - 04:01 EDT
Update
We continue to implement a fix provided by the third party who experienced a global outage today and are seeing positive resolutions to impacts including resolution for the following applications:
Raiser’s Edge
Raiser’s Edge NXT
Financial Edge
Financial Edge NXT

We will continue to update as additional applications are fully restored.
Posted Jul 19, 2024 - 23:34 EDT
Update
We continue to implement a fix provided by the third party who experienced a global outage today and are seeing positive resolutions to impacts including resolution for the following applications:
Raiser’s Edge
Raiser’s Edge NXT
Financial Edge
Financial Edge NXT

We will continue to update as additional applications are fully restored.
Posted Jul 19, 2024 - 23:32 EDT
Update
We continue to implement a fix provided by the third party who experienced a global outage today and are seeing positive resolutions to impacts including resolution for the following applications:
Raiser’s Edge
Raiser’s Edge NXT
Financial Edge
Financial Edge NXT

We will continue to update as additional applications are fully restored.
Posted Jul 19, 2024 - 23:28 EDT
Update
The issue impacting multiple products continue to see progress towards resolution as we repair impacted servers. Our engineers continue to work diligently to deploy the fix from the third-party provider. Throughout the repair actions, the amount of customers impacted continues to grow smaller and we will ensure all are operational as soon as possible.
Posted Jul 19, 2024 - 20:12 EDT
Update
The issue impacting multiple products continue to see progress towards resolution as we repair impacted servers. Our engineers continue to work diligently to deploy the fix from the third-party provider. We will continue to provide updates as they are available.
Posted Jul 19, 2024 - 17:53 EDT
Update
The issues impacting multiple products continue to see positive progress towards resolution. Our team has made significant advancements in deploying a fix from the third-party provider and is working to investigate possible downstream impacts. Thank you for your patience.
Posted Jul 19, 2024 - 15:18 EDT
Update
We continue to implement a fix provided by the third party who experienced a global outage today and are seeing positive resolutions to impacts including:

Payment processing
eTapestry functionality
Major functionality within Education Management solutions

Thank you for your patience, please continue to monitor this page for further updates.
Posted Jul 19, 2024 - 13:26 EDT
Update
Our team continues to collaborate with external partners and internal resources to find a resolution. We are seeing positive progress in some areas:

Payment processing has been restored.
eTapestry functionality has been restored.
Major functionality within Education Management solutions is returning, though some issues remain.

We are still experiencing various issues across our solutions and appreciate your patience.
Posted Jul 19, 2024 - 10:56 EDT
Update
Our team continues to collaborate with external partners and internal resources to find a resolution. We are seeing positive progress in some areas:

Payment processing has been restored.
eTapestry functionality has been restored.
Major functionality within Education Management solutions is returning, though some issues remain.

We are still experiencing various issues across our solutions and appreciate your patience.
Posted Jul 19, 2024 - 10:46 EDT
Update
Our team continues to collaborate with external partners and internal resources to find a resolution. We are seeing positive progress but know there is still impact. Users will experience a wide variety of impacts that customers have reported. Examples include:

Real-time and batch payments failing to process.
Inability to log into solutions including database view.
Various functionality inside solutions may not function or be accessible.
Donation forms may not load.
Posted Jul 19, 2024 - 10:11 EDT
Update
Our team continues to collaborate with external partners and internal resources to find a resolution. We are seeing positive progress but know there is still impact. Users will experience a wide variety of impacts that customers have reported. Examples include:

Real-time and batch payments failing to process.
Inability to log into solutions including database view.
Various functionality inside solutions may not function or be accessible.
Donation forms may not load.
Posted Jul 19, 2024 - 08:47 EDT
Update
Like thousands of other services across the world, Blackbaud solutions are currently being impacted by this third-party global IT outage. We’re working with our partners and internally to find a resolution.
Posted Jul 19, 2024 - 06:28 EDT
Update
Like thousands of other services across the world, Blackbaud solutions are currently being impacted by this third-party global IT outage. We’re working with our partners and internally to find a resolution.
Posted Jul 19, 2024 - 05:09 EDT
Identified
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 04:30 EDT
Investigating
Multiple services are currently being affected by a 3rd party global technical issues. Our engineers are currently working to restore services as and when the 3rd party issue is resolved. Please continue to reference this page for updates.
Posted Jul 19, 2024 - 04:01 EDT
Identified
Multiple services are currently being affected by a 3rd party global technical issues. Our engineers are currently working to restore services as and when the 3rd party issue is resolved. Please continue to reference this page for updates.
Posted Jul 19, 2024 - 04:00 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 02:59 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 02:51 EDT
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause and we have all the appropriate engineers available to get your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted Jul 19, 2024 - 02:43 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 02:42 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 02:06 EDT
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jul 19, 2024 - 01:35 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 19, 2024 - 01:04 EDT
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™, Blackbaud MobilePay™, Payments API, Blackbaud MobilePay Terminal), Blackbaud Grantmaking™ (Blackbaud Grantmaking™), Blackbaud Financial Edge NXT® (Accounts Payable API, Financial Edge NXT, General Ledger API, Statistical Unit API, Treasury API), Blackbaud Raiser's Edge NXT® (Communication Preference API (Beta), Constituent API, Fundraising API, Gift API, Online Registration Service (Beta), Opportunity API, Raiser's Edge NXT®, List API (Beta), Email Marketing, Prospect Insights), YourCause® (YourCause® CSRconnect®), and Blackbaud Altru®, Blackbaud CRM™, Blackbaud NetCommunity™, Grateful Patient Solution, JustGiving® from Blackbaud®, Payment Services, ResearchPoint™.