Active Issue Alert – Education Edge, Faculty Access for the Web - #2019090601
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted 15 days ago. Sep 06, 2019 - 11:12 EDT
Identified
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted 15 days ago. Sep 06, 2019 - 10:49 EDT
Update
We are continuing to investigate this issue.
Posted 15 days ago. Sep 06, 2019 - 10:02 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted 15 days ago. Sep 06, 2019 - 10:01 EDT
This incident affected: Education Edge (Education Edge, Faculty Access for the Web).