Active Issue Alert – WealthPoint® - #000592789

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 09:19 EDT

Investigating

We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 13, 2025 - 09:09 EDT