Active Issue Alert – Blackbaud ID – Multiple Products - 000685870

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 16:12 EDT

Update

We are continuing to investigate an issue impacting a sub-set of Blackbaud ID users utilizing Facebook authentication. As a workaround users can convert their account to utilize another social sign-in option. https://kb.blackbaud.com/knowledgebase/articles/Article/208610
The next update is tomorrow, August 4 at 5:00 PM ET.
Posted Aug 03, 2026 - 17:32 EDT

Update

We are continuing to investigate an issue impacting a sub-set of Blackbaud ID users utilizing Facebook authentication. As a workaround users can convert their account to utilize another social sign-in option. https://kb.blackbaud.com/knowledgebase/articles/Article/208610
The next update is on Monday, August 3 at 5:00 PM ET.
Posted Jul 31, 2026 - 17:25 EDT

Update

We are continuing to investigate an issue impacting a sub-set of Blackbaud ID users utilizing Facebook authentication. As a workaround users can convert their account to utilize another social sign-in option. https://kb.blackbaud.com/knowledgebase/articles/Article/208610
The next update is tomorrow, July 31 at 5:00 PM ET.
Posted Jul 30, 2026 - 16:53 EDT

Update

We are continuing to investigate an issue impacting a sub-set of Blackbaud ID users utilizing Facebook authentication. As a workaround users can convert their account to utilize another social sign-in option. https://kb.blackbaud.com/knowledgebase/articles/Article/208610
Next update will be by 5pm ET.
Posted Jul 30, 2026 - 12:49 EDT

Update

We have identified an issue impacting a sub-set of users who sign in to Blackbaud products using the "Sign in with Facebook" option through BBID. Affected users may be unable to access their Blackbaud products. Our engineers are actively investigating the cause and are working to restore service as quickly as possible. Please continue to monitor this page for updates.
Posted Jul 30, 2026 - 10:14 EDT

Update

We are continuing to investigate this issue.
Posted Jul 29, 2026 - 16:37 EDT

Investigating

We identified an issue that may prevent you from signing in with your Blackbaud ID or using features in the solutions below. We’re working to diagnose and resolve the issue as quickly as possible. Please continue to check this page for updates.
Posted Jul 29, 2026 - 16:01 EDT
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™), Blackbaud Education Management Solutions (Blackbaud School Website System™, Blackbaud Enrollment Management System™, Blackbaud Learning Management System, Blackbaud Student Information System™, Core Functionality, School API, Blackbaud Billing Management™), Blackbaud Grantmaking™ (Blackbaud Grantmaking™, Blackbaud Outcomes™), Blackbaud.com (Blackbaud.com, signin.blackbaud.com, Blackbaud ID), Blackbaud Fundraiser Performance Management™ (Blackbaud Fundraiser Performance Management™, FPM Data Integration), Blackbaud Altru®, Blackbaud CRM™, Blackbaud eTapestry®, Blackbaud Guided Fundraising™, Blackbaud Tuition Management™, Financial Edge®, JustGiving® from Blackbaud®, Raiser's Edge®, ResearchPoint™, Blackbaud Financial Edge NXT® (Financial Edge NXT), and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).