Active Issue Alert – Financial Edge NXT - 000642747

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 12:16 EDT

Update

Engineers have identified the issue and are working on a fix. We anticipate the fix to be deployed within the next few hours. Please continue to reference this page for updates.
Posted Oct 29, 2025 - 10:25 EDT

Investigating

Engineers have identified the issue and are working on a fix. We anticipate the fix to be deployed within the next few hours. Please continue to reference this page for updates.
Posted Oct 29, 2025 - 10:01 EDT
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT).