Active Issue Alert – Blackbaud Luminate Online® - 000644477

Incident Report for Blackbaud

Resolved

An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 07, 2025 - 09:20 EST

Identified

Our engineers have identified and deployed a fix for this iATS incident. It may take some time to propagate across all sites. Please continue to reference this page for updates. The next update will be at 9:00am ET.
Posted Nov 06, 2025 - 21:41 EST

Update

We have identified an issue impacting a subset of customers using iATS payment processing. Our engineering team is actively investigating the root cause and working to implement a fix as quickly as possible.
Posted Nov 06, 2025 - 17:43 EST

Investigating

We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Nov 06, 2025 - 17:42 EST
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).