Active Issue Alert – Luminate Online - 000678801

Incident Report for Blackbaud

Resolved

An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jun 17, 2026 - 09:58 EDT

Monitoring

Our engineers have deployed the patch to production environments this afternoon to resolve this issue. We will continue to monitor.

The next update will be provided at 10:00 AM EDT on Wednesday, June 17. Please continue to reference this page for updates.
Posted Jun 16, 2026 - 16:13 EDT

Update

Our engineers have finished testing the new patch to address recent issues impacting registration and personal page updates for a subset of participants. We will deploy the patch to production environments today. There will be no downtime.

The next update will be provided at 4:00 PM EDT on Tuesday, June 16 at the latest. Please continue to reference this page for updates.
Posted Jun 16, 2026 - 09:56 EDT

Update

Our engineers have developed a patch to address recent issues impacting registration and personal page updates for a subset of participants. We are completing final testing in staging environments and targeting early this week for deployment.
The next update will be provided at 10:00 AM EDT on Tuesday, June 16. Please continue to reference this page for updates.
Posted Jun 15, 2026 - 16:28 EDT

Update

Our engineers are continuing to develop a patch to address recent issues impacting registration and personal page updates for a subset of participants.

The next update will be provided at 4:00 PM EDT on Monday, June 15. Please continue to reference this page for updates.
Posted Jun 15, 2026 - 10:23 EDT

Identified

Our engineers deployed a fix this afternoon to resolve the issue impacting TeamRaiser personal page updates. While most updates are now functioning as expected, a subset may still experience issues. We’ve identified the root cause of these remaining cases and are actively working on an additional patch. Default personal page content should continue to update successfully.
The next update will be provided at 10:00 AM EDT on Monday, June 15. Please continue to reference this page for updates.
Posted Jun 12, 2026 - 16:20 EDT

Update

Our engineers are implementing a change to mitigate this issue. We expect the update to be live later this afternoon. Please continue to check this page for the latest information.
Posted Jun 12, 2026 - 14:02 EDT

Update

We have identified an issue that is preventing personal page updates for a subset of participants. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jun 12, 2026 - 13:53 EDT

Update

We have identified an issue that is preventing personal page updates for a subset of participants. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jun 12, 2026 - 13:06 EDT

Investigating

We have identified an issue that is preventing personal page updates for a subset of participants. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jun 12, 2026 - 12:41 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).