A subset of customers are receiving "Something Went Wrong" or "522" errors when accessing Blackbaud Academic Works websites. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 17, 2025 - 10:58 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 17, 2025 - 10:43 EDT
This incident affected: Blackbaud Award Management™.