Active Issue Alert – YourCause CSRconnect
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Sep 21, 2020 - 11:02 EDT
Investigating
We are aware of an issue impacting the CSRConnect platform. Customers are reporting that they receive multiple errors when attempting to check out on the platform. Engineers are currently investigating root cause. We will continue to keep you posted on their progress
Posted Sep 21, 2020 - 10:05 EDT
This incident affected: YourCause® (YourCause® CSRconnect®).