Active Issue Alert – Financial Edge NXT, Raiser's Edge NXT, & Core Functionality in Education Management - 000270672
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jul 28, 2021 - 11:06 EDT
Update
We are continuing to investigate this issue.
Posted Jul 28, 2021 - 10:42 EDT
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jul 28, 2021 - 10:30 EDT
This incident affected: Financial Edge NXT (Financial Edge NXT), Blackbaud Education Management Solutions (Core Functionality), and Raiser's Edge NXT (Raiser's Edge NXT).