Active Issue Alert – Raiser's Edge NXT - 000593856

Incident Report for Blackbaud

Resolved

An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Mar 18, 2025 - 12:41 EDT

Update

Users accessing the Donor Portal may encounter an error or prompt that the connection is not private. Our engineers are working to resolve this for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 18, 2025 - 12:35 EDT

Update

Users accessing the Donor Portal may encounter an error or prompt that the connection is not private. Our engineers are working to resolve this for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 18, 2025 - 12:10 EDT

Update

Users accessing the Donor Portal may encounter an error or prompt that the connection is not private. Our engineers are working to resolve this for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 18, 2025 - 11:50 EDT

Investigating

We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Mar 18, 2025 - 11:36 EDT
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).