Active Issue Alert – Blackbaud Education Management Solutions - #000366085
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jun 14, 2022 - 10:43 EDT
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jun 14, 2022 - 10:10 EDT
This incident affected: Blackbaud Education Management Solutions (Blackbaud School Website System, Blackbaud Enrollment Management System, Blackbaud Learning Management System, Blackbaud Student Information System, Core Functionality, School API, Blackbaud Billing Management (EAP), Smart Aid).