Active Issue Alert – Rasisers Edge NXT - 000596647

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Mar 29, 2025 - 06:13 EDT

Monitoring

We are investigating an issue impacting some of our customers. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 29, 2025 - 06:06 EDT
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).