Active Issue Alert – Blackbaud.com - #000664979

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 17:10 EDT

Update

For users attempting to access their Blackbaud Solutions or systems please go to app.blackbaud.com or directly to your product URL to sign in.
Posted Mar 19, 2026 - 16:33 EDT

Investigating

We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 19, 2026 - 16:29 EDT
This incident affected: Blackbaud.com (Blackbaud.com).