Our engineers have identified an issue causing some pages to be inaccessible. The root cause has been identified, and work is underway to restore affected sites as quickly as possible. Please continue to monitor this page for updates.
Posted Sep 10, 2026 - 10:22 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Sep 10, 2026 - 10:03 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).