Active Issue Alert – Financial Edge NXT- #000085717
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Nov 08, 2019 - 13:32 EST
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Nov 08, 2019 - 13:12 EST
This incident affected: Financial Edge NXT (Financial Edge NXT).