Active Issue Alert – Luminate Online - #000604458

Incident Report for Blackbaud

Resolved

Our engineers identified an issue that was causing a subset of donors to experience latency and a spinning circle when attempting to donate. We have resolved this issue and have seen no further indication of these errors.
Posted May 02, 2025 - 16:08 EDT

Update

Our engineers identified an issue that was causing a subset of donors to experience latency and a spinning circle when attempting to donate. We have resolved this issue and have seen no further indication of these errors.
Posted May 02, 2025 - 15:51 EDT

Investigating

We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted May 02, 2025 - 15:46 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).