Active Issue Alert – Blackbaud Learning Management System - #2019091201
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted 8 days ago. Sep 12, 2019 - 13:27 EDT
Investigating
We are aware of an issue affecting Assignment Drop Box. It is affecting the ability to upload and annotate assignments.
Posted 8 days ago. Sep 12, 2019 - 13:01 EDT
This incident affected: Blackbaud Education Management Solutions (Blackbaud Learning Management System).