Resolved Issue Alert – Luminate Beta and Raiser's Edge NXT - #2018112704
Incident Report for Blackbaud
Resolved
We identified an issue impacting a small subset of our Luminate Beta and Raiser's Edge NXT customers causing errors when attempting to send emails. Please note that emails sent between Our engineers have successfully implemented a fix and services are now restored. If you have any questions about status in the future, you can always get updates at this page.
Posted Nov 27, 2018 - 14:43 EST