Active Issue Alert – Raiser's Edge NXT - 000670987

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 11:53 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2026 - 11:48 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 27, 2026 - 11:39 EDT

Investigating

We have identified an issue impacting some of our customers impacting their ability to load constituent page features or prompting errors while navigating to different areas of the application.  Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 27, 2026 - 11:23 EDT
This incident affected: Raiser's Edge®.