Active Issue Alert – Award Management - 000286242
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Sep 15, 2021 - 09:59 EDT
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Sep 15, 2021 - 09:36 EDT
This incident affected: Blackbaud Award Management (formerly AcademicWorks).