Resolved Issue Alert – Luminate Online - 000670753

Incident Report for Blackbaud

Resolved

Our engineers identified an issue causing digital wallets from not displaying correctly. Service has since been restored and the issue is now resolved. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Apr 24, 2026 - 10:53 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).