Active Issue Alert – Raiser's Edge NXT - #2019082301
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted 29 days ago. Aug 23, 2019 - 09:29 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted 29 days ago. Aug 23, 2019 - 09:01 EDT
This incident affected: Raiser's Edge NXT (Raiser's Edge NXT).