Active Issue Alert – Raiser's Edge NXT - #000089145
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 21, 2019 - 12:30 EST
Identified
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Nov 21, 2019 - 11:32 EST
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).