We are currently investigating an issue that is affecting both internal and external access to our Support Portal and Knowledgebase search pages. Our engineers have diagnosed the issue and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 02, 2026 - 19:36 EDT
Investigating
We are currently investigating an issue that is affecting both internal and external access to our Support Portal and Knowledgebase search pages. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 02, 2026 - 15:41 EDT
This incident affected: Blackbaud Website Package.