Active Issue Alert – Raiser's Edge, Financial Edge NXT - 000667840

Incident Report for Blackbaud

Update

A subset of customers are experiencing intermittent latency while navigating in Database View. This typically manifests as visual disruptions when rendering user interface elements and does not impact process runtimes. Our engineers continue working to resolve this for you as quickly as possible. Next update will be 11 AM ET, 13 Apr 2026. Please continue to reference this page for updates.
Posted Apr 09, 2026 - 14:04 EDT

Update

A subset of customers are experiencing intermittent latency while navigating in Database View. This typically manifests as visual disruptions when rendering user interface elements and does not impact process runtimes. Our engineers continue working to resolve this for you as quickly as possible. Next update will be 1 PM ET, 9 Apr 2026. Please continue to reference this page for updates.
Posted Apr 08, 2026 - 16:13 EDT

Update

A subset of customers are experiencing intermittent latency when navigating, or using features such as lists, in Database View. Our engineers continue diagnosing the event and working to resolve it for you as quickly as possible. Next update will be 3:30 PM ET. Please continue to reference this page for updates.
Posted Apr 08, 2026 - 11:12 EDT

Update

A subset of customers are experiencing intermittent latency when navigating, or using features such as lists, in Database View. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 07, 2026 - 16:34 EDT

Investigating

We have identified an issue impacting a subset of our customers causing errors when using Database View with Raiser's Edge NXT and Financial Edge NXT. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 07, 2026 - 15:55 EDT
This incident affects: Blackbaud Financial Edge NXT® (Financial Edge NXT) and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).