Active Issue Alert – Financial Edge NXT - #000672553

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted May 06, 2026 - 21:25 EDT

Identified

Restoration efforts are ongoing and will continue into the evening. Please continue to reference this page for updates.
Posted May 06, 2026 - 17:38 EDT

Update

Engineers have identified the cause of this issue and are working to restore access for impacted customers. Database view access may be one of the first things restored as the solution comes back online, with Web view access restoration to follow. Please continue to reference this page for updates, the next of which should be no later than 5:30 PM.
Posted May 06, 2026 - 15:27 EDT

Investigating

A small subset of customers are experiencing the following error when attempting to login: "That’s odd… Unable to perform the requested database operation". Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted May 06, 2026 - 12:50 EDT
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT).