Active Issue Alert – Blackbaud ID – Multiple Products - #2018112801
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 28, 2018 - 15:01 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 28, 2018 - 15:00 EST
Monitoring
A fix has been implemented for the issue with one of our vendors that was preventing users from signing in with their Blackbaud ID intermittently or using features in the solutions below. We will continue to monitor the situation and update this page with any new information as it becomes available. Next update will be at 3PM EST unless there is a change before that time.
Posted Nov 28, 2018 - 13:48 EST
Update
We are aware of an issue with one of our vendors that may prevent anyone from signing in with their Blackbaud ID or using features in the solutions below. We’re working with this vendor to resolve the issue as quickly as possible. Please continue to check this page for updates. Next update will be at 2PM EST unless there is a change before that time.
Posted Nov 28, 2018 - 13:13 EST
Identified
We are aware of an issue with one of our vendors that may prevent anyone from signing in with their Blackbaud ID or using features in the solutions below. We’re working with this vendor to resolve the issue as quickly as possible. Please continue to check this page for updates. Next update will be at 2PM EST unless there is a change before that time.
Posted Nov 28, 2018 - 11:55 EST
This incident affected: Blackbaud Education Management Solutions (Blackbaud School Website System™, Blackbaud Enrollment Management System™, Blackbaud Learning Management System, Blackbaud Student Information System™), Blackbaud Grantmaking™ (Blackbaud Grantmaking™), Blackbaud Financial Edge NXT® (Accounts Payable API, Financial Edge NXT, General Ledger API, Statistical Unit API, Treasury API), Blackbaud Altru®, Blackbaud eTapestry®, ResearchPoint™, DonorCentral® NXT, Blackbaud Raiser's Edge NXT® (Constituent API, Fundraising API, Gift API, Opportunity API, Raiser's Edge NXT®), and Blackbaud Merchant Services™ (Payments API).